Back to overview
Degraded
Support Center is down
Nov 02 at 02:50am CET
Affected services
Support Center
Resolved
Nov 02 at 03:18am CET
Support Center recovered.
Affected services
Created
Nov 02 at 02:50am CET
Support Center is degraded.
Affected services