Back to overview
Degraded
Support Center is down
Feb 24 at 02:17am CET
Affected services
Support Center
Resolved
Feb 24 at 02:24am CET
Support Center recovered.
Affected services
Created
Feb 24 at 02:17am CET
Support Center is degraded.
Affected services