Back to overview
Downtime

Admin panel: Degraded performance

Aug 19, 2022 at 8:05am UTC
Affected services
Admin Panel

Resolved
Aug 19, 2022 at 8:24am UTC

Admin panel has been restored

Created
Aug 19, 2022 at 8:05am UTC

We're investigating reports of an issue with admin panel. We will provide more information shortly.